[ale] need working dialup

Dow Hurst Dow.Hurst at mindspring.com
Sun Dec 19 21:35:48 EST 2004

I meant that you authenticate in the chat script and not during PPP 
negotiation.  Arrrghh!!!  Bad thought process and worse typing here...

In DSL you authenticate during PPP setup and after LCP completes.  In 
dialup you connect, authenticate in the chat script, then autostart PPP, 
or look for a tilde in the next few frames of data from the server to 
"see" that it is trying to start PPP.

I've used the above method with wvdial and the full email address for 
earthlink/mindspring for years.

Dow Hurst wrote:

> Did you get it going?  LCP failure is before authentication on DSL but 
> not on dialup since your chat script ought to authenticate you, IIRC.  
> For Earthlink you have to have your primary email address for the 
> account as the login and the password as the password for that primary 
> email account.   I don't see your login and password expect send 
> pairs.  So your connected but not authenticated  so PPP is ignored at 
> this point.  At least for earthlink, I would connect, authenticate, 
> and the just start PPP on my own and forget waiting for the server to 
> start PPP.  wvdial does a good job of this.  Also, you can demand dial 
> in this situation.
> Dow
> Mark Wright wrote:
>> Hi all,
>> I am exasperated. (ooh I even spelled it right)
>> I have been trying for three months in my spare time to set up a nice 
>> little Linux box for my mom.  She badly needs a replacement for here 
>> Apple IIsi.  She is on dial up.  I am a computer professional.  
>> Whatever that means.  I have been repairing Mainframes since 85.  I 
>> used dial up back when every modem command and network option had to 
>> be entered by hand on whatever tty device we were lucky enough to 
>> have.  So why can't I get a Linux distro to connect to Earthlink?
>> I have tried FC2, Mandrake 9.2, and 10.0, Knoppix 2.0, Linspire 4.5, 
>> and Ubuntu.  I have two identical US robotics 56K modems that work 
>> fine on any machine.  One of them was working on an OS2 box only a 
>> few months ago.
>> FC2 had a strange issue with the modem that I corrected via a tip I 
>> found online.  All the others auto sense the modem and dial it 
>> correctly without help.  I get to the same place with al the 
>> different distos.
>> From /var/log/message on Ubuntu:
>> chat [24230]: send (ATST6782454201)
>> chat [24230]:  expect (connect)
>> chat [24230]:  ^M
>> chat [24230]:  CONNECT
>> chat [24230]:  - - got it
>> chat [24230]:  send  (/d)
>> pppd [24227]:  Serial connection established
>> pppd [24227]:  Using interface ppp0
>> pppd [24227]:  Connect :  ppp0  <--> /dev/ttyS0
>> pppd [24227]:  LCP:  timeout sending config-Requests
>> pppd [24227]:  Connection terminated
>> pppd [24227]:  Hangup  (SIGHUP)
>> pppd [24227]:  Exit .
>> I have printed a three inch notebook full of HOW-TO's from the 
>> internet.  I have followed many rabbit trails.  I have read ppp set 
>> up instructions from 1996 but I have no answers.  I have tried to set 
>> up my Speedfactory account with a local dial up number to verify that 
>> it is not Earhtlink being funny.
>> Is any one using a Linux machine with a modem.   I am willing to buy 
>> an internal or another external or really anything that will make it 
>> work.
>> I have looked at every file associated with communication for config 
>> and privileges but will gladly go over anything again.  If you have a 
>> working configuration I would love to compare.  Sorry this is so long 
>> but I am only scratching the surface.
>> Any ideas?
>> Thanks,
>> Mark Wright
>> _______________________________________________
>> Ale mailing list
>> Ale at ale.org
>> http://www.ale.org/mailman/listinfo/ale
> _______________________________________________
> Ale mailing list
> Ale at ale.org
> http://www.ale.org/mailman/listinfo/ale

More information about the Ale mailing list