[ale] Me again

John M. Mills jmills at jmills.gtri.gatech.edu
Tue Jan 13 21:39:47 EST 1998


Good thing you asked this question today.  Yesterday my answer would have
been more complex.  Here's what worked for me:

1) As you would probably have guessed, the best answer for the cbj610 is:
"Canon CBJ-600 and CBJ-4000" -- also select "360x360" resolution, and
"Send EOF After Job".  You shouldn't need "Fix Stair-Stepping".  Accept
the settings and go ahead and print the ASCII test page to be sure.

2) Bring up your favorite editor (well, you had to start with one soon,
anyway ;-), and (as 'root'), go to the spool directory of your printer:
(typically /var/spool/lpd/lp for RH4.2) and edit the file 'postscript.cfg'
to disable the 'COLOR' line.  Mine now looks like this:

# configuration related to postscript printing
# generated automatically by PRINTTOOL
# manual changes to this file may be lost
# COLOR=-dBitsPerPixel=3

# following is related to printing multiple pages per output page

See - I just added the "#" ahead of the word: COLOR=
You could just as well simply delete that line entirely.

Save the file back where it was, and try the Postscript test page.  If
your system is like mine, it will now print without crashing Ghostscript.
Hopefully, the hat will really be red.  Let me know.

If this doesn't work, you will have to look around for another "filter"
to use, but that is a fairly limited problem compared to the ones you
have already solved.

It looks like you are making great progress.  Stay on the mailing list and
soon you'll be helping others solve problems.

If you go back to the control panel and create a duplicate print driver
for the sampe port, you can play with things like this without disturbing
your primary printer.

  John M. Mills, Senior Research Engineer -- john.mills at gtri.gatech.edu
  Georgia Tech Research Institute, Georgia Tech, Atlanta, GA 30332-0834
         Phone contacts: 404.894.0151 (voice), 404.894.6285 (FAX)
             "Lies, Damned Lies, Statistics, and Simulations"

On Tue, 13 Jan 1998, Tri Ngo wrote:

> Hi, it's me again. Last time I wrote to you I asked you what Linux destribution was good. I was the 13 year old remember? Well I decided to get Red Hat Linux 5.0. It installed great. I used Lynx to get onto the internet to download Netscape and installed it. So far so good. So I was surfing the internet in on Netscape in Linux when I found this really interesting document I wanted to print out. So I figured I had to setup my printer. I went to the utility printtool in X windows to set it up. I have a canon 610, but I found only a canon 600 driver and the documention said it should work so I tried it. I tested by selecting the print asci from the test menu. That worked without a glitch. Then I tested it by printing a postscript file. The printer seemed like it was recieving some info but it didn't print. So I kept on trying some options and it started to print some stuff. Instead of printing what it's supposed to it printed an error message and stopped:
> Unrecoverable error rangecheck in putdeviceprops
> (1488) op_array(458)0x8130244:Execution stack at 0x80f4310:
> 0x80fbc94: 0x0f oper --F---e-- 0x0000 0x08052f00 = %interp_exit
> 0x80fbc9c: 0x03 file --G-rxe-- 0x0001 0x081306b4
> 0x80fbca4: 0x05 mpry --G-rxe-- 0x0002 0x0813119c
> 0x80fbcac: 0x05 mpry --G-rxe-- 0x0039 0x081318f6
> I know its not my printer because I used the canon 10e driver and it worked but without color. I need some help. Please!!!!
> Tri Ngo
> PS I live in atlanta tucker

More information about the Ale mailing list