[ale] configuring getty for dialOUT logins

The Wayward Mage fireeyes at gstv.gsu.edu
Sat Aug 3 06:01:45 EDT 1996

On Fri, 2 Aug 1996, Joe wrote:
> This sounds like an interrupt conflict or some such. I have just
> managed to get a Wyse 60 hooked up to COM4 (ttyS3) on my machine, and
> I initially saw symptoms similar to this - then I realized that (a) My
> ppp connection was up, and (b) my modem (on ttyS1) was sharing
> interrupt 5 with ttyS3. Killed off ppp, everything worked. I can even
> leave a getty on that terminal while ppp is up, as long as I don't
> actually try to log in :-)

I know the interrupt is right because it worked once.  If the interrupt
was wrong, it never would have worked that one time.
> In general, look at the following:
> (1) Do you need a null-modem adapter? (probably)

I have one.
> (2) Ensure that the two machines agree about such issues as
> transmission speed, flow control (XON/XOFF vs RTS/CTS vs none), byte
> size, stop bits, and parity. You can find all these things out by
> using stty and setserial, but _read the man pages_ for those things,
> because the output is rather cryptic, and need not mean what you
> naively assume it does.

complete agreement.
> (3) Make really sure that you are talking on the ports you think you
> are. I've done a lot of work on troubleshooting serial line troubles,
> and I have been known to religiously believe I had my software talking
> to comX, but found out through some weird circumstance that it was
> really configured for some different com port. (D'oh)

ports are set right.
> (4) If you have access to a protocol analyzer or a "blinky-box"
> (serial breakout box), stick it in the loop to make sure you're data
> is getting out of the serial port. A blinky box costs about $10 at
> Radio Shack; it has LEDs on it that show you when the xmt and rcv and
> flow control signals are active.

don't have one of those...I'll check into it.
> Good luck,

Thanks. :)


More information about the Ale mailing list