[ale] NIS and NFS

Bryan E. Rank bryan at cc.gatech.edu
Fri Aug 2 09:29:03 EDT 1996

I am also having the same problem as Al, and was wondering if anyone
else has gotten this to work.  I am also using RedHat (3.0.3), the only
difference in our problems seems to be that he dumps core, whereas if I
leave mine up long enough, I get rpctimeout messages.

When I run ypbind I get...

cleared entry for domain <the_correct_domain>: server, port 0
parsing config file
Trying entry: domainname <the_correct_domain> server <the_correct_server>

parsed domain name broadcast
cleared entry for domain <the_correct_domain>: server, port 0
broadcasting for domain <the_correct_domain>
received signal 2

...I have also set the domain name using domainname, and it matches
the one that I get by issuing the same command on the ypserver.

My /etc/yp.conf file looks like this...
domainname <domain_I_get_from"domainname"on_server> server <server_name>

...I can ping everything and my machine name is in the netgoup file on
the server.  The maps have been remade and the server is running
ypserve and ypbind.  

The address of the server is in /etc/resolv.conf.

I have put nis in my /etc/host.conf file it reads...
order nis hosts
...I have tried reversing this order and putting multi on. 

Any help would be appreciated.

Bryan Rank

> Hello,
> I'm working on a lone Linux machine in a sea of SUN's.  I'd like to be 
> able to use NIS for user accounts (passwords) and NFS to mount user home 
> directories.  I'm having trouble finding sufficient documentation on how 
> to accomplsh this.  In particular, there is no useful NFS howto (the only 
> thing I can find is for doing NFS installs), and the steps in the NIS 
> documentation require that one execute:
> 	/bin/domainname-yp <domain name>
> While /bin/domainname-yp does not exist on my machine, domainname does 
> and gives me no errors upon execution (using the same domain name as that 
> used by my SUN - I determined this name using the names of files in the 
> /var/yp/bindings directory on the SUN.  This makes sense, right?)  
> However, when I follow this command (as specified in the NIS howto) with:
> 	/usr/sbin/ypbind
> I get a core dump.  The client yp executables that I have (ypbind, ypcat, 
> ypmatch, ypasswd, ypwhich) were installed as part of the RedHat (3.0.3) 
> installation.  Are there known problems with these?  Is this crash a 
> known bug that only I don't know about?  Otherwise, what am I doing wrong?
> In general, any pointers to good information on NIS and NFS would be much 
> appreciated - especially if it's taylored to the Linux environment in 
> particular...

More information about the Ale mailing list