[ale] SOLVED - CIFS mounts failing

Derek Atkins warlord at MIT.EDU
Tue Nov 22 11:11:11 EST 2016

Okay, so why exactly does this work?  What does this registry entry do?


DJ-Pfulio <DJPfulio at jdpfu.com> writes:

> Remember a few months ago when I asked for help with Windows CIFS mounts
> that normally worked, but sometimes failed?  Didn't matter if Linux or
> Windows clients attempted access?  Didn't matter if a GUI tool or
> mount.cifs was used.
> The error was:
>      mount: Remote I/O error
> Found the solution today.  Registry entry needed on the Windows side.
>      \SYSTEM
>       \CurrentControlSet
>        \Services
>         \LanmanServer
>          \Parameters
>     IRPStackSize DWORD 0x0000000f (15)
> It is case-sensitive and after creating the IRPStackSize, need to
> restart the "Services" windows service.  Then it works, immediately.
> _______________________________________________
> Ale mailing list
> Ale at ale.org
> http://mail.ale.org/mailman/listinfo/ale
> See JOBS, ANNOUNCE and SCHOOLS lists at
> http://mail.ale.org/mailman/listinfo

       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the Ale mailing list