[ale] syncing a palm via serial/usb device?

Geoffrey esoteric at 3times25.net
Wed Feb 18 20:06:19 EST 2004

Jason Day wrote:
> On Wed, Feb 18, 2004 at 06:40:30PM -0500, Geoffrey wrote:
>>I do not see a reference to two ports.  This really doesn't make sense 
>>to me, because ttyUSB0 and ttyUSB1 are two different physical hardware 
>>ports.  I've moved it to another port, I still get ttyUSB0.  I'm sure 
>>it's just taking the first available.
> Ok, that's a start.  The visor driver isn't working properly, for
> whatever reason.  I don't fully understand how the usb stuff works
> either, but I do know that the ttyUSB? ports don't necessarily
> correspond to physical USB ports, and that the visor driver needs two
> ports to work.

There is an additional driver that's necessary for the converter.  I'm 
wondering if the visor driver and that driver are not playing nicely. 
I've tried it with one, then the other and then with both, loading them 
in a different order.

I really don't get the issue of two ports.  Every box I've ever had has 
always had the same number of ttyUSB? devices as physical ports.  My 
previous mb had two and I had ttyUSB[0-1], this one has 4 and I've got 

> What kernel version are you using?  A newer kernel might fix the
> problem.  Also, some people have reported problems with hotplug loading
> the visor driver.  Blacklisting the visor driver and loading it manually
> with insmod seems to fix a lot of problems.

kernel is 2.4.21  I've removed and reinstalled the module, no luck.

> And finally, if none of that helps, try asking the pilot-link folks,
> here:
> http://www.pilot-link.org/mailman/listinfo/pilot-link-general

Thanks, I'll likely head over to the usb list as well.

Until later, Geoffrey                     Registered Linux User #108567
Building secure systems inspite of Microsoft

More information about the Ale mailing list