[ale] FTP weirdness

Bob Kruger bkruger at mindspring.com
Wed Apr 25 07:16:37 EDT 2001


I pulled the man file for ftp and did a search, but could find nothing on "passive
mode."  I have missed something here...

"Joseph A. Knapka" wrote:

> Leonard Thornton wrote:
> >
> > Is your Linux box you are going through your firewall/NAT box?  With your
> > Linux clients that work through this box, have you tried setting PASSIVE
> > mode off and seeing if they work?

> >
> > If this box IS a firewall/NAT box, you need to make sure that ftp-data port
> > is open inbound AND that it is MASQ'd properly.  Look at elofw.sh out on
> > www.linux.org for an example of how to do this....You can test this by
> > setting your Linux ftp clients to use ACTIVE mode rather than PASSIVE for
> > transfers.  If this is your problem, your Linux clients will failed in
> > ACTIVE mode.

Like I said, the ftp clients for linux boxes in the sub net work fine.  This only
crops up with the windows machines that also use the firewall.  Before going to the
new kernel, all worked.

> You can also "insmod ip_masq_ftp.o" to get active connections to work
> properly.

Joe - I think this is only pertinent for the older 2.2.x kernels.  I am still using
IP chains, though, and compiled the kernel accordingly.

Getting closer....


To unsubscribe: mail majordomo at ale.org with "unsubscribe ale" in message body.

More information about the Ale mailing list